Mercado fechado
  • BOVESPA

    110.036,79
    +2.372,44 (+2,20%)
     
  • MERVAL

    38.390,84
    +233,89 (+0,61%)
     
  • MXX

    44.626,80
    -475,75 (-1,05%)
     
  • PETROLEO CRU

    79,74
    -1,49 (-1,83%)
     
  • OURO

    1.668,30
    -0,30 (-0,02%)
     
  • BTC-USD

    19.408,61
    -65,70 (-0,34%)
     
  • CMC Crypto 200

    443,49
    +0,06 (+0,01%)
     
  • S&P500

    3.585,62
    -54,85 (-1,51%)
     
  • DOW JONES

    28.725,51
    -500,10 (-1,71%)
     
  • FTSE

    6.893,81
    +12,22 (+0,18%)
     
  • HANG SENG

    17.222,83
    +56,96 (+0,33%)
     
  • NIKKEI

    25.937,21
    -484,84 (-1,83%)
     
  • NASDAQ

    11.058,25
    -170,00 (-1,51%)
     
  • BATS 1000 Index

    0,0000
    0,0000 (0,00%)
     
  • EURO/R$

    5,3079
    +0,0099 (+0,19%)
     

Como fazer sorteio no Excel | Guia completo

Talvez não seja algo intuitivo, mas tem como fazer sorteio no Excel. Além de uma série de ferramentas onlines e apps, o editor de planilhas da Microsoft conta com duas funções (ALEATÓRIOENTRE e PROCV) que podem ajudar os usuários a automatizarem um sorteio sem precisar fazê-lo por fora. Confira abaixo mais detalhes!

Preparando a tabela para o sorteio

Antes de usar as fórmulas, você deve preparar a tabela para o sorteio. Na primeira coluna dela, atribua valores, de preferência, crescentes, que vão representar o código ou ID. Na coluna do lado, você deve adicionar os nomes.

O primeiro método sorteará um número, então basta apenas fazer a correlação entre o ele e o nome. Já o segundo método, usará uma fórmula que vai sortear um número e buscar automaticamente o nome associado a ele.

Como fazer sorteio no Excel usando a fórmula ALEATÓRIOENTRE

A fórmula ALEATÓRIOENTRE do Excel vai buscar um valor aleatório entre um valor mínimo e um valor máximo, e deve ser escrita da seguinte forma: =ALEATÓRIOENTRE(valor mínimo; valor máximo).

  1. Abra uma planilha do Excel e selecione uma célula;

  2. Insira a fórmula =ALEATÓRIOENTRE(valor mínimo; valor máximo). Para nosso exemplo, o que deve ser inserido é =ALEATÓRIOENTRE(1;9), que irá sortear um valor entre 1 e 9;

  3. Caso as células possuam números, você poderá inserir as células no lugar dos números. Para este exemplo, ficará: =ALEATÓRIOENTRE(A4;A12);

  4. Assim que você apertar “Enter”, a função irá retornar um valor aleatoriamente. Então, você poderá localizar o número do lado de um nome.

    Veja como fazer sorteio no Excel usando a fórmula ALEATÓRIOENTRE (Captura de tela: Matheus Bigogno)
    Veja como fazer sorteio no Excel usando a fórmula ALEATÓRIOENTRE (Captura de tela: Matheus Bigogno)

Como fazer sorteio no Excel usando a fórmula PROCV

A fórmula PROCV do Excel possui a seguinte estrutura: =PROCV(valor procurado; intervalo da busca; índice da busca; procurar por valores aproximados). Como ela faz uma busca baseada em um valor, para fazer um sorteio, o pulo do gato está em passar a função ALEATÓRIOENTRE no campo “valor procurado”, que sorteará um valor aleatório.

Com o valor aleatório, a função PROCV é capaz de identificar o nome relacionado a esse número e retorná-lo. Confira abaixo o passo a passo mais detalhado:

  1. Comece digitando o início da fórmula =PROCV( em uma célula;

  2. O primeiro campo, que é o valor buscado, vamos inserir a função ALEATÓRIOENTRE. Para este exemplo, vai ficar =PROCV(ALEATÓRIOENTRE(1;9);

    Comece inserindo a fórmula PROCV e, no valor procurado, a função ALEATÓRIOENTRE (Captura de tela: Matheus Bigogno)
    Comece inserindo a fórmula PROCV e, no valor procurado, a função ALEATÓRIOENTRE (Captura de tela: Matheus Bigogno)
  3. Em seguida, vamos inserir o intervalo da tabela. Para o exemplo, vai ficar =PROCV(ALEATÓRIOENTRE(1;9);A4:B12;

    No campo da tabela, insira o intervalo da sua tabela (Captura de tela: Matheus Bigogno)
    No campo da tabela, insira o intervalo da sua tabela (Captura de tela: Matheus Bigogno)
  4. Insira o índice da coluna que deve ser retornado. Como a intenção é que a fórmula retorne o nome, então, o índice é da coluna 2 da tabela. Para o exemplo, ficará =PROCV(ALEATÓRIOENTRE(1;9);A4:B12;2;

    Insira o índice da coluna que deve ser retornado (Captura de tela: Matheus Bigogno)
    Insira o índice da coluna que deve ser retornado (Captura de tela: Matheus Bigogno)
  5. Por último, você deve inserir se quer ou não que a fórmula retorne um valor aproximado. Como se trata de um sorteio, queremos apenas o valor exato, então, o atributo é FALSO. Então, ficará =PROCV(ALEATÓRIOENTRE(1;9);A4:B12;2;FALSO);

    Insira FALSO para informar à fórmula que você não quer valores aproximados (Captura de tela: Matheus Bigogno)
    Insira FALSO para informar à fórmula que você não quer valores aproximados (Captura de tela: Matheus Bigogno)
  6. Aperte “Enter” para que a fórmula calcule um valor aleatório a ser buscado e, em seguida, retorne o nome atrelado a esse número, concluindo assim, o sorteio pelo nome.

    Veja como fazer sorteio no Excel usando a fórmula PROCV (Captura de tela: Matheus Bigogno)
    Veja como fazer sorteio no Excel usando a fórmula PROCV (Captura de tela: Matheus Bigogno)

Fonte: Canaltech

Trending no Canaltech: