Mercado fechado
  • BOVESPA

    110.036,79
    +2.372,44 (+2,20%)
     
  • MERVAL

    38.390,84
    +233,89 (+0,61%)
     
  • MXX

    44.626,80
    -475,75 (-1,05%)
     
  • PETROLEO CRU

    79,74
    -1,49 (-1,83%)
     
  • OURO

    1.668,30
    -0,30 (-0,02%)
     
  • BTC-USD

    19.442,28
    -84,77 (-0,43%)
     
  • CMC Crypto 200

    443,49
    +0,06 (+0,01%)
     
  • S&P500

    3.585,62
    -54,85 (-1,51%)
     
  • DOW JONES

    28.725,51
    -500,10 (-1,71%)
     
  • FTSE

    6.893,81
    +12,22 (+0,18%)
     
  • HANG SENG

    17.222,83
    +56,96 (+0,33%)
     
  • NIKKEI

    25.937,21
    -484,84 (-1,83%)
     
  • NASDAQ

    11.058,25
    -170,00 (-1,51%)
     
  • BATS 1000 Index

    0,0000
    0,0000 (0,00%)
     
  • EURO/R$

    5,3079
    +0,0099 (+0,19%)
     

Como fazer PROCV entre duas planilhas do Excel | Guia prático

Utilizar fórmulas no Excel é uma das ações mais usadas no programa da Microsoft. Por isso, é interessante saber como fazer PROCV entre duas planilhas do Excel. O procedimento é simples e permite buscar por informações em arquivos diferentes.

Conheça, a seguir, para que serve a fórmula e aprenda, no tutorial, como fazer PROCV no Excel entre duas planilhas distintas. Dica vale para as versões desktop e web (online) do editor de planilhas.

Para que serve a fórmula PROCV

PROCV é uma abreviação de “Procura na Vertical” que tem por objetivo buscar dados em uma coluna (portanto, na vertical). Também serve para interligar informações entre tabelas, evitando dados duplicados ou possíveis erros de digitação.

É por isso que fazer PROCV no Excel ajuda principalmente em casos que você queira localizar itens específicos em tabelas com grandes quantidades de dados. Assim, a fórmula automatiza a busca, evitando que você faça essa pesquisa manualmente, podendo levar mais tempo que o necessário.

Como fazer PROCV entre duas planilhas

Basicamente, fazer PROCV entre duas planilhas no Excel consiste em aplicar a fórmula na célula de uma tabela em branco, na primeira planilha, e depois selecionar a tabela inteira da segunda planilha. É importante destacar que as duas planilhas do Excel precisam ter pelo menos uma coluna com as mesmas informações. Assim, a fórmula PROCV poderá cruzar os dados entre os dois arquivos.

No exemplo do tutorial, vamos pesquisar a porcentagem de comissão presente na "Planilha 2" e levá-la até a "Planilha 1".

  1. Inicie o Excel no seu dispositivo;

  2. Abra as duas planilhas que você quer fazer PROCV;

  3. Na “Planilha 1”, clique em uma célula em branco (célula "F4") na tabela na qual você quer cruzar um dado da “Planilha 2”;

  4. Aplique a fórmula PROCV na célula de uma coluna na “Planilha 1”. No exemplo, vamos usar “=PROCV(E4;” (sem aspas), para que a coluna "Bairro" sirva de referência para as duas planilhas;

    Insira a fórmula "=PROCV(" acompanhada da célula (Captura de tela: Caio Carvalho)
    Insira a fórmula "=PROCV(" acompanhada da célula (Captura de tela: Caio Carvalho)
  5. Na “Planilha 2”, selecione toda a tabela e digite ponto e vírgula mais o número de colunas da tabela. Neste caso, como são duas tabelas, fica “;2”. Logo na sequência, digite “;0”;

  6. Aperte a tecla “Enter" no teclado. A fórmula final do nosso exemplo será “=PROCV(E4;Planilha2!B3:C13;2;0)".

    O resultado final da fórmula PROCV compartilhada entre duas planilhas (Captura de tela: Caio Carvalho)
    O resultado final da fórmula PROCV compartilhada entre duas planilhas (Captura de tela: Caio Carvalho)

Automaticamente, você verá o resultado da fórmula PROCV entre duas planilhas na primeira planilha aberta.

Como dica final para fazer PROCV entre duas planilhas, você ainda pode usar a fórmula para completar todo o espaço em branco de uma coluna, na primeira planilha, usando os dados da segunda planilha. Para isso:

  1. Clique na célula com a fórmula PROCV pronta. No exemplo, é a célula “F4”;

  2. Selecione o intervalo das células da “Planilha 2” (“B3:C13”);

  3. Pressione a tecla “F4” no teclado. Um cifrão ("$") será adicionado entre cada sentença;

    Selecione o intervalo das duas células na segunda planilha e pressione F4 no teclado (Captura de tela: Caio Carvalho)
    Selecione o intervalo das duas células na segunda planilha e pressione F4 no teclado (Captura de tela: Caio Carvalho)
  4. Aperte “Enter" no teclado”;

  5. Clique duas vezes na primeira célula (“F4”), segure e arraste até o final da coluna.

    A fórmula PROCV será aplicada automaticamente nas demais células (Captura de tela: Caio Carvalho)
    A fórmula PROCV será aplicada automaticamente nas demais células (Captura de tela: Caio Carvalho)

O Excel aplicará automaticamente a PROCV em todas as células selecionadas, procurando informações na segunda planilha e cruzando os dados. Assim, você não precisará fazer a fórmula manualmente em cada tabela.

Fonte: Canaltech

Trending no Canaltech: